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ViaLactea Visual Analytics, Release 1.4

The ViaLactea Service is aimed at exploiting astrophysical surveys of the Galactic Plane to study the star formation
process of the Milky Way. The ViaLactea Visual Analytics (VLVA) tool combines different types of visualization
to perform the analysis exploring the correlation between different data, for example 2D intensity images with 3D
molecular spectral cubes. All underlying data are managed by the ViaLactea Knowledge Base (VLKB). The VLKB
includes 2D and 3D (velocity cubes) surveys, numerical model outputs, point-like and diffuse object catalogues and
allows for retrival of all the available datasets as well as cutouts on the positional and/or velocity axis and some merging
capabilities on adjacent datasets.

See terms and privacy.

For more details about the ViaLactea Visual Analytics tool and its aspects please refere to F. Vitello et al. 2018 PASP
130 084503.
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CHAPTER

ONE

INTRODUCTION

The ViaLactea Software is developed in two main components: the ViaLactea Knowledge Base (following referred as
VLKB) and the ViaLactea Visual Analytics (following referred as VLVA).

The VLKB documentation is available here.

VLVA is based on the VisIVO suite and offers a 2D and 3D visual analytics environment allowing the astronomers to
easily conduct research activities interacting in a simple way with the VLKB and its services.

For more details about the ViaLactea Visual Analytics Tool and its aspects please refere to F. Vitello et al. 2018 PASP
130 084503.
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CHAPTER

TWO

INSTALLATION

VLVA is an open-source software available for macOS and Linux systems. The source code is available on GitHub.

To manually build and install VLVA (with its dependencies), follow the steps provided here.

Pre-compiled DMG and Debian packages are available on the GitHub Releases page.

2.1 Docker container

VLVA is also available as a Docker container. The container leverages Virtual Network Computing (VNC) and can be
easily accessed through a browser.

To start a new container, use the following command:

$ docker run -it -e SIZEW=1920 -e SIZEH=1080 -e CDEPTH=24 -e SHARED=TRUE -e␣
→˓VNCPASS=vncpasswd -p 5901:5901 neaniasspace/vialacteavisualanalytics:latest

Then open a browser and go to http://localhost:5901/. The default password is “vncpasswd” (see the VNCPASS value
defined in the Docker command).

Before starting VLVA change the scaling mode (Settings → Scaling Mode → Remote Resizing) and enable fullscreen
(see Fig. 2.1).

Now you can start VLVA using the icon on the desktop.
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Fig. 2.1: VNC settings

Fig. 2.2: ViaLactea Docker container
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CHAPTER

THREE

CONFIGURATION

VLVA settings can be changed by selecting File → Settings (ViaLacteaVisualAnalytics → Preferences on macOS) in
the menu bar of the main window.

Fig. 3.1: Settings window
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IDL (or GDL) is needed to perform SED Fitting operations on the local machine. Typically in macOS the binary
executable path is /Applications/exelis/idl/bin/idl; in Linux is /usr/local/bin/idl).

The Tile path is required to show the Galactic Plane view on the main window and it is the openlayers.html absolute
path. It can be either local (on the local computer) or remote. By default a URL of the Tile path is provided and enabled.

The glyph max value is used for the 3D visualization of compact sources. The default (and maximum) value for this
option is 2147483647.

It is possible to select which VLKB instance the tool will connect to. Currently there are three active VLKB instances:
the public access hosted at INAF-OATS, the private access also hosted at INAF-OATS, and the NEANIAS instance.
By default, the public instance is selected. The private and the NEANIAS instances are restricted to authenticated
users. The private instance requires an username and a password. The NEANIAS instance, instead, requires the user
to login via the NEANIAS SSO.

Users who want to use the NEANIAS instance must request access to the service through the NEANIAS Service
Management System.

8 Chapter 3. Configuration
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CHAPTER

FOUR

MAIN WINDOW

The Main Window shows an interactive view of the galactic plane (longitude from -180° to +180° and latitude from
-2° to 2°). This view can be used to perform a visual selection of the region of interest.

The selection of the region can be carried out choosing a point on the map and then specifying the radius of selection,
or picking up a rectangular region.

It is also possible to specify the surveys and wavelengths for the VLKB query using the checkboxes on the right panel.

Fig. 4.1: Main window interface

Clicking on the Query button, VLVA sends the query to the VLKB and then opens on a separate window the FITS
image containing selected region, in the chosen survey and wavelength, that is used as starting point for performing the
visual analytic operations.

9
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VLVA allows to load a FITS file image that is locally stored on the user’s computer by clicking on the Local Image
button.

Similarly, the Local DC button allows to load and visualize a velocity datacube FITS file that is already stored on a
local disk. When loading a datacube, VLVA will also compute the zeroth moment map which will be visualized as a
2D image layer. The VLKB search functionality is also extended to imported files.

The Select button under the 3D section allows to specify the range of coordinates on which to perform a 3D visualization
of compact sources on the galactic plane (3D visualization of compact sources).

10 Chapter 4. Main Window



CHAPTER

FIVE

IMAGE VISUALIZATION

Once the selected region has been downloaded or locally loaded from the Main Window, the 2D visualization window
is shown.

By default, a grey color palette is used to visualize the image. The color palette can be changed using a predefined one
embedded in the tool, for each of them is possible to select whether to use linear or logarithmic scale.

The image can be zoomed with the mouse wheel and panned dragging it when the SHIFT button is pressed.

Contrast and saturation of the image can be changed by holding the left mouse button and moving on the image. The
bottom of the window shows the pixel value pointed by the mouse cursor, along with the coordinates expressed as pixel
(X, Y), galactic (GLON, GLAT), fk5 (RA, DEC) and ecliptic (RA, DEC) as shown in Fig. 5.1.

Fig. 5.1: Information of the pixel pointed by the mouse cursor

On the top-right panel there is a list (following referred as VLKB inventory) of images and datacubes available in the
ViaLactea Knowledge Base related to the visualized region. A single click on a inventory item shows a footprint on
top of the visualized image to display the area covered by the item (Fig. 5.2). The elements with a full overlap with the
image can be recognized by the green background.

Furthermore, the following operations can be carried out:

• Adding a new layer image

• Compact sources visualization

– SED Analysis

• Filaments visualization

5.1 Adding a new layer image

A new layer image can be added by double-clicking a Continuum item on the VLKB inventory, or by loading a local
file from the Main Window. In the latter case the image must be compatible, i.e. there must be an overlap among the
images.

New layers are aligned (position, scaling pixel size, rotation) to the “image base” using the information contained in
their header.

Each layer is listed in the bottom-right panel (see Fig. 5.3). This panel is organized as a reverse stack: the user eye is
on the bottom of this stack and sees all activated layers by transparency. It is possible to move a layer up or down in
the stack to change the visualization order.

11
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Fig. 5.2: Footprint visualization

The checkbox on the left of each row can activate or deactivate the visualization of the relative layer. The opacity,
the color palette and the scale of each layer can be modified in the Layer setting panel located in the upper part of the
window.

5.2 Compact sources visualization

VLVA allows to visualize compact sources overlapped to the fits image.

To query the VLKB for compact sources, click on the Compact Source button (or use the keyboard shortcut cmd + R
on macOS system or ctrl + R on Linux) and make a rectangular selection of the region of interest on the visualized
image.

VLVA extracts the coordinates from the selection and shows a window to query the VLKB (see Fig. 5.4).

By default, VLVA queries the VLKB to obtain sources from the bandmerged table. It is possible to download and
visualize the compact sources of just one band by selecting the desired one from a dropdown list Table in the panel.

The Query button sends the query to the VLKB and if there are any results, VLVA will automatically displays the
compact sources on top of the image (see Fig. 5.5).

The compact sources are shown in different colors on the image depending on the relative wavelength. Similarly to the
layers management, by using the checkbox it is possible to select which compact sources to display. It is also possible
to change the color used to show the sources in the visualization by double-clicking on the colored rectangle of each
row.

12 Chapter 5. Image visualization
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Fig. 5.3: Visualization of several layers

5.2.1 SED Analysis

To perform SED analysis, from the menu bar go to Window → Select (or use the keyboard shortcut cmd + S on macOS
system or ctrl + S on Linux), select one or more of the visualized clumps and click on the SED button. Fit operations
are performed in a transparent way for the user locally using integrated IDL routines or remotely. In the latter case, a
Java JRE is required to communicate with the remote service.

There are three different kinds of fitting operations available, one for the fit with the theoretical models and two for
the analytical fit. Fitting operations are performed from the menu bar selecting Action → Fit → Theoretical model or
Action → Fit → Grey-body. It is also possible to perform the fitting operations by clicking on the buttons on the right
panel (see Fig. 5.6).

In case the SED presents multiple associations, it is possible to sum the fluxes of counterparts obtaining the SED with
a cumulative flux. This operation is done by checking Collapse All from the right panel.

If the Multi Select visualization mode is activated, the fit operation is performed only on the selected nodes on the
graph.

The bottom panel in this window shows either the output logs or the results of the SED fitting operation. A list of fits
appears once a new fit is performed. Each one can be checked to show it on the plot. The Clear All button removes all
the plotted fits (see Fig. 5.7).

5.2. Compact sources visualization 13
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Fig. 5.4: Compact Source query window
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Fig. 5.5: Visualization of compact sources retrieved from the VLKB

5.3 Filaments visualization

Similarly to the compact sources query, filament structures can be visualized by selecting the Filaments button on top
of the window and making a rectangular selection.

The filaments are displayed with contour and spine on top of the image as shown in Fig. 5.8. Their colors and visual-
ization can be changed in the same way as the compact sources.

5.3. Filaments visualization 15



ViaLactea Visual Analytics, Release 1.4

Fig. 5.6: SED plot

16 Chapter 5. Image visualization



ViaLactea Visual Analytics, Release 1.4

Fig. 5.7: SED plot: in blue the theoretical fit performed on the selected SED

5.3. Filaments visualization 17
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Fig. 5.8: Filaments visualization
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CHAPTER

SIX

DATACUBE VISUALIZATION

When the user selects a datacube from the VLKB inventory, or when they load a datacube from their local disk, VLVA
opens a new window to visualize datacube.

Fig. 6.1: Datacube visualization

The 3D datacube visualization (left panel) can be controlled by the mouse movements. The camera can be reset to
pre-defined views using the Camera Menu, e.g. Camera → Front will place the camera in front of the datacube.

The 3D visualization can be zoomed with the mouse wheel and panned holding the SHIFT key.

The datacube visualization is rendered using isosurfaces algorithm with the threshold specified by the Threshold slider
located in the top panel.

The right panel shows a slice of the velocity datacube. The slice is selected using the Cutting Plane slider.

Any changes to these sliders will update the visualization in real-time.

Contrast and saturation of the visualized slice can be changed by holding the left mouse button and moving the cursor
on the image. The bottom of the window shows the pixel value pointed by the mouse cursor, along with the coordinates
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expressed as pixel (X, Y), galactic (GLON, GLAT), fk5 (RA, DEC) and ecliptic (RA, DEC).

6.1 Isocontours

If the Contours checkbox is enabled, the isocontours are displayed on top of the selected slice as shown in Fig. 6.2. The
contours are also reported on the 2D map image. Contours settings can be modified by changing the Level, the Upper
bound and Lower bound values.

Fig. 6.2: Contours visualization

6.2 Moment maps

VLVA allows to compute the zeroth and the first moment maps and visualize them as a new layer on top of the 2D image
currently open. From the datacube window, the zeroth moment map is computed by clicking on the menu Moment →
Calculate order 0. The results is shown in Fig. 6.3.

20 Chapter 6. Datacube visualization
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Fig. 6.3: Contours and zeroth moment map visualization on the 2D image

6.2. Moment maps 21
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CHAPTER

SEVEN

3D VISUALIZATION OF COMPACT SOURCES

The 3D visualization can be performed by clicking on the Select button of the Main Window (see Fig. 4.1) and then
typing the region bounds (in degrees) of the area of interest.

Fig. 7.1: 3D Visualization of sources on galactic plane

The 3D view is interactive and the camera position can be moved with mouse operations. The color palette can be
mapped to a pre-defined field (e.g. temperature) in the Lut box in the top panel. The scale and range values can also
be changed.

The shape and the scaling factor of each source can be modified in the Glyph panel. The points are scaled based on the
selected field (e.g. mass). The maximum number of glyphs visualized is set in the Settings (Fig. 3.1).
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CHAPTER

EIGHT

LOCAL SESSION MANAGEMENT

VLVA allows to save the work session and restore it later. The session is a folder containing a JSON configuration file
and all the files required to resume the visual analysis operations.

8.1 Saving a session

The session includes:

• the image layers and their settings (color palette, scale, transparency level, whether or not they are visualized);

• compact sources (color, whether or not they are visualized);

• filaments (color, whether or not they are visualized);

• datacube windows and their settings (threshold, cutting plane and contours values).

To save the session, from the 2D visualization window go to menu File → Save session and then select an empty folder
on the local disk. If you try to save a previously loaded or already saved session, the tool will ask whether to overwrite
the current session or save it in a separate folder.

8.2 Loading a session

To load a session, from the Main Window go to menu File → Load session and then select the session.json file
inside a session folder. VLVA will restore the status of the work session as it was saved.
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